Customers may encounter errors while using the editor.
Incident Report for Vimeo
Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 11:41 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2024 - 10:30 EDT
Investigating
We are currently investigating this issue.
Posted Sep 09, 2024 - 07:52 EDT
This incident affected: Create and API.