Homepage is not loading

Incident Report for Vimeo

Postmortem

What happened

On September 4, between approximately 10:00 AM and 11:00 AM EDT, some Vimeo users experienced partially rendered pages across the site. Affected pages displayed the top menu bar but were missing portions of the expected page content.

What caused it

During a site update, some required files weren’t uploaded correctly.

How we responded

We received internal notification of the issue almost as it occurred and began investigating immediately. We quickly confirmed the outage and reverted to a prior stable version of Vimeo. This restored all affected pages within one hour. We then investigated the root cause and implemented a permanent fix by roughly 1:30 PM.

What we’re doing to prevent a recurrence

We changed the order in which Vimeo source code is uploaded and checked so that lagging updates won’t cause similar outages in the future.

Posted Sep 11, 2025 - 09:35 EDT

Resolved

Current Status: mitigated
Current Action: The issue with the homepage and login not loading has been resolved.
Posted Sep 04, 2025 - 10:29 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 04, 2025 - 10:27 EDT

Update

Current Status: detected
Current Action: Vimeo.com homepage and login are having issues loading
Posted Sep 04, 2025 - 10:24 EDT

Investigating

We are currently investigating this issue.
Posted Sep 04, 2025 - 10:22 EDT
This incident affected: Website.